[Maxima] nintegrate function
andrej.vodopivec at gmail.com
Thu May 24 15:40:28 CDT 2007
> Well, that's not quite true, is it? You don't want it to try to
> compute an antiderivative.
> I think you should rename the function to quadpack_front_end
> or something less suggestive than nintegrate.
nintegrate implies numerical integration, but it does not imply which
algorithm it uses (romberg, quad_qag, quad_qags, qaud_qagi). In maple
I can use evalf(Int(...)) to do numerical integration, I don't need to
know how it does it. In mathematica NIntegrate[..] does numerical
integration and I don't need to know how it does it. It is a matter of
personal choice but I prefer to use names which tell what function
does instead of how it does something. I prefer realroots to
whater_algorithm_it_uses. Function names should be suggestive.
More information about the Maxima