[Maxima] run_testsuite interface change?
raymond.toy at ericsson.com
Mon Jan 19 10:04:29 CST 2009
Robert Dodier wrote:
> On 1/19/09, Raymond Toy <raymond.toy at ericsson.com> wrote:
>> Something like
>> run_testsuite(display=<t/f>, known_bugs=<t/f>, tests=<list of tests>)
> OK by me. Instead of display and known_bugs, I am inclined to name
> the parameters display_all and display_known_bugs.
Works for me.
> At present, the elements of the list of tests must be strings;
> I think symbols should be allowed also.
> i.e. [rtest10, rtest15] as well as ["rtest10", "rtest15"].
I'll see if I can make it accept symbols and strings.
More information about the Maxima